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TEMEL BİLGİSAYAR KULLANIMI DERSLERİ 
 

FİREWORKS (RESİM İŞLEME) PROGRAMI 
 

UYGULAMA 1: PORTRE ÇALIŞMASI 

 

Yeni bir dosya açarken aşağıdaki linki kullanabiliriz.  

 
 

Oluşturacağımız sayfanın genişlik (width) yükseklik (height) Zemin (Canvas) ayarlamalarını yapalım.  

 
 

 

Başka bir resimden bir bölümü seçerek Ctrl+C ile kopyalayalım. Kopyaladığımız kısmı Canvas ölçülerini ayarladığımız 

167x169 luk sayfaya atalım.  

 
 

Diğer sayfaya kopyaladıktan sonra dikkat edersek kopyaladığımız resmin orada bulunan zeminden daha büyük olduğunu 

görürüz. Resmin ölçülerini zeminle aynı yapmamız gereker. Bu işlem için sol taraftaki Tools (araçlar) içerisinden Scale Tool 

(Ölçekleme aracı) nı seçelim ve resmi küçültelim. 
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Zemindeki çerçeve ile (167x169) ile üzerine eklediğim resmin kenarları orantılı olmadığı için resmin çok az bir kısmı 

zeminin dışında kalmıştır.  

 
 

Bu fazlalık kısımları otomatik olarak kırpmak için Modify>Canvas>Trim Canvas yolunu kullanalım. Bu işlemden sonra 

resmin zemini taşan kısımları kırpılmış olacaktır.  
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Sayfada görmüş olduğumuz bu resim içerisinde iki tane çerçeve vardır. Bunlardan bir tanesi Canvas dediğimiz Zemin 

çerçevesi, diğeri ise üzerinde gördüğümüz resmin kendisidir. Buna da image (Resim) diyeceğiz. Her ikisininde boyutlarını 

ayarlamak için Modify>Canvas yolunu kullanabiliriz.  

 
 

Şimdi resim üzerinde bazı düzeltme işlemleri yapalım. Öncelikle kişinin sakalındaki dağınık görünümü düzeltelim. Bunun 

için soldaki araçlardan “Smudge Tool” seçelim. Bu araç el işareti görünümünde olup bir yerden boyayı alıp diğer yere doğru 

sürükler. Bu işlemi daha uygun yapabilmek için Size (boyut) , Edge (kenar) ve Pressure (basınç) ayarlarını yapalım. Daha 

sonra boyun bölgesindeki ve yaka bölgesindeki renkleri sakal üzerine doğru bastırarak sürükleyelim. Ve aşağıdaki görünümü 

elde edelim.  
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Resmin üzeri bazı bölgeler karanlık kaldıysa yada portrenin genel görünümü flaş kullanmadan çekildi ise, bunların dışında 

esmer olan bir kişiyi açık tenli hale getirmek istiyor isek sol taraftan “Dodge tool” aracını kullanabiliriz. Bu aracı kullanırken 

exposure (ortaya çıkarma)  özelliğini biraz daha düşük tutmak lazım. Bu aracı kullanarak boyun kısmında karanlık bölgeyi 

biraz daha açtık.  
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Arka plana resim ekleme. Resmin görüneceği alan öncelikle silinmiş olması lazım. Yukarıda Lasso Tool (kement aracı) 

kullanılarak kişinin omuz bölgesi temizlenmişti. Bu bölgede Canvas (beyaz renk) görünür hale geldi.  

 

Böyleyken başka bir manzara resmi açıp, bu resmin belli bölgesini seçip keselim. Ctrl X ile.  Daha sonra üzerinde 

çalıştığımız adam resminin olduğu sayfaya geçelim. Buraya yapıştıralım. Ctrl V ile.  

 

Dikkat edersek eklediğimiz manzara resmi kişinin yüzünü kapattı. Bunu engellemek için sağ taraftan layers (tabakalar) 

ekranından manzaranın bulunduğu layerı kişinin bulunduğu layerın altına sürükleyelim. Yani sıralamayı değiştirelim. Bu 

durum kişi üstte manzara altta gözükecektir. Eğer manzara çok büyük olup çok az bir kısmı kişinin omuzlarından görünüyor 

ise manzarayı biraz küçültelim. Bu işlem için sol taraftan Scale Tool (ölçekleme aracı) nı seçelim.  

 

 
 

Eklediğimiz resmin zeminde taşan kısımlarını kırpmak için yukarıda yaptığımız gibi Modify>Canvas>Trim Canvas ı seçerek 

kırpalım. 
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Burada iki tane ayrı resim (adam ve manzara) ve bir zemin vardır. Resimleri tek bir resim haline (yapışmış hale ) getirmek 

için Ctrl A ile herşeyi seçelim. Ardından Modify>Flatten Selection komutunu çalıştıralım.  

 

 
 

Not: Eğer ileride resmin görünümü üzerinde değişiklik yapmak isterseni bu tabakalı halin düzleştirdiğiniz için gerekli 

değişiklikleri yapamazsınız. Örneğin manzara resmini tekrar değiştiremezsiniz. Resmin bu halini korumak ister iseniz Flatten 

Selection fazla kullanmamanızı tavsiye ederiz. Zaten resmi dışarıya atarken Jpg uzantılı kaydettiğimizde resim tek bir resim 

halinde gözükecektir. Resmin Png olarak kaydedersek Tabakalı hali korunmuş olarak kaydedilmiş olur.  

 

Resmi kaydederken iki farklı versiyon halinde kaydedebiliriz. Uzantısını Png olarak kaydedersek layerları (tabakaları) 

koruyarak  kaydetmiş oluruz. Jpg uzantılı olarak kaydedersek resmin yer kapladığı hafıza azalır ve resim tek parça haline 

gelmiş olur. her iki haldede kaydetmek fayda vardır. Bu işlem için File>Save As kullanarak kaydedebiliriz.  

 

 
 

Dikkat edersek kaydettiğimiz yerde jpg uzantılı olan resim 33 kb yer kapladı. Png uzantılı olan ise 223 kb yer kapladı. 

 

UYGULAMA 2: WEB SAYFASI BAŞLIK ÇALIŞMASI 

 

Web sayfasının üst kısmında buluna resmi tamamen yeniden tasarlayarak değiştirelim. Bunun gerekli uygulamaları yapalım.  
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İlk olarak tasarlanacak olan resmin ölçülerin okuyup kenara kaydedelim.  

 
 

Resmin alt kısmın köşeleri yuvarlak turuncu renkli bir dökdörtgen çerçeve atalım.  

 
 

İç kısma mavi bir dikdörtgen daha atalım. Bu dikdörtgenin köşesi daha küçük yarıçaplı olsun. Dikdörtgeni seçip aşağıda 

properties penceresinden + işaretine tıklayıp Glow efekti verelim. Bu efekt komple çevresine renk atacaktır. Efekti seçtikten 

sonra açılan pencereden bazı ayarlarını değiştirilim. 

 

 



KARABÜK ÜNİVERSİTESİ, MÜHENDİSLİK FAKÜLTESİ, TEMEL BİLGİSAYAR KULLANIMI NOTLARI..............www.IbrahimCayiroglu.com 

 

 8 

 
 

Eğer kullandığımız efekti tamamen kaldırmak istiyor isek aşağıdan Glow yazısına tıklayıp  - (eksi ) işaretine tıklayalım. 

Şayet düzetme yapmak istiyorsak aynı yerde bulunan i harfine tıklayalım ve çıkan pencereden gerekli değişiklikleri yapalım.  

 
 

Burası eksik kaldı. Daha sonra tamamlanacak ??? 

 

 

UYGULAMA 3: REKLAM BANNER (AFİŞ) TASARIMI 

 

Öncelikle sitemizde Reklam afişini koyacağımız alanı belirleyelim. Bu alan web sitemizdeki sağ alt köşede bulunan alan 

olsun. Buranın boyutlarını alıyoruz. 206x169 luk bir alan olduğunu görüyoruz.  

 
 

Buradaki resmi kaldırıp yerine hazırladığımız Reklam Bannerını kullanacağız.  İlk olarak Reklamın ilk görünümüne 

koyacağımız bir resim bulalım. Bu resmi Word programında Küçük Resimler kısmından alalım.  Ve üzerine bir yazı 

yazalım. Bu yazının çevresine Glow atarak yazıyı daha belirgin hale getirelim. Aşağıdaki şekilde olsun.  
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Hazırlayacağımız reklam bennarı hareketli bir banner olsun. Bunun için “Frame” (Çerçeve) dediğimiz uygulamayı 

yapacağız. Yani sırayla gösterilecek Frameleri ayarlayıp içerisine değişik resimler ekleyeceğiz. Bu uygulama için Fireworks 

da Window>Frames kısmından ilgili pencereyi açalım. 

 
 

Bir reklam banner ı hazırladığımızda ilk görüntümüz Frame1 in içerisindedir. Hareketli resimler hazırlarken bir çok frame 

ihtiyaç duyarız. Her frame içersinde ise yeni bir tasarım yapılması gerekir. Mevcut frame’in devamı olarak yeni bir frame 

eklemek için Frames Penceresinin sağ üst köşesindeki yere tıklayıp “Add Frames” ve “Duplicate Frame” yazının çıktığı 

pencereyi açın. Burada “Add Frames” yeni boş frame eklemek için kullanılır. “Duplicate Frame” ise daha önceki mevcut 

framen aynı kopyasını yeni frame çıkarmak için kullanılır.  
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Frame2 yi oluşturduktan sonra Üzerine aşağıdaki şekilde bir tasarım yapın. 

 
 

Bu tasarımdaki yazıyı dikey hale getirmek için aşağıdaki yolu kullanın. 

 

 
 

Bu şekilde 5 tane Frame (film karesi) hazırlayın 
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Yapmış olduğumuz çalışmanın hareketli halini izlemek için Ekranın alt kısmındaki Play/Stop tuşlarına tıklayın. Eğer çok 

hızlı hareketli ise sağ taraftan frame ekranından sürelerini değiştirin.  

 
 

 

Çalışmayı dışarı kaydederken önce Reklam.png olarak daha sonra Reklam.gif (Animated gif) olarak kaydedin.  

 
 

NOT: Eğer hazırladığınız animasyon hızı sizin hazırladığınız hızda çalışmıyor ise aşağıdaki şekilde Animated Gif seçeneği 

seçildikten sonra Sağ alt köşedeki Options butonuna basıp, tamam deyip öyle kaydedin.  
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UYGULAMA 4. DAİRE ÇEVRESİNE YAZI YAZMA (LOGO ÇALIŞMASI) 

 

Yapacağımız logo çalışmasında bir dairenin çevresine yazı yazmayı deneyeceğiz. Diğer kısımları ise Fireworksun normal 

araçların kullanacağız.  

 

Elips aracını seçip Shift tuşuna basılı tutarak daireyi çizin. Daha sonra dairenin zemin rengini (sarı renk) ve Çizgi rengini 

(mavi renk) belirleyin. Çizgi kalınlığını 2 piksel olarak ayarlayın.  

 

 
 

Dıştaki dairenin içerisine bir tane daha daire yerleştirin. İki daire birbiri merkezli olsun. Orantılı yerleşsin. İçteki dairenin 

kenar bir yere kopya sını çıkarın. Eğer sayfada boş bir yer yok ise Canvas dan zeminin ölçüsünü artırın. Çıkardığımız kopya 

daireyi sol taraftaki “Knife tool” ile iki bölün.  
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Parçalara ayırdığımız üstteki çizgi ile yazdığımız bir yazıyı seçip yukarıdan Text>Attach To Path seçeneğini seçerek yazı ile 

çizgi ile çizgiyi birleştirelim.  

 

 
 

Birleştirdikten sonra yazının ortalı olması için yazıyı seçip aşağıdan A\V ile gösterilen kısımdan sayıyı büyütün. Burası 

yazının karekterleri arasına boşluk atacaktır. Ve böylece yazı çizgiyi daha dolduracaktır. Yazının ilk kısmına Space (boşluk 

tuşu) ile bir miktar boşluk atıp daha ortalı hale getirebilirsiniz.  

 

 
Karabük üniversitesi yazısını sarı logonun üst kısmına taşıyarak yerleştirelim. Eğer oradaki oradaki yere küçük geliyorsa 

Scale aracı ile yazıyı bir miktar büyütelim. Şeklin üst kısmına yazıyı ortalayalım.  

 

Daha sonra logonun alt kısmına yerleştirilek işkur yazısı ile  ona şekil verecek çizgiyi çizgiyi seçelim. Aynı şekilde 

Text>Attach To Path yolunu kullanarak bu iki şekli birleştirelim. 
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Birleştirdiğimizde eğer yazı ters duruyor ise birleştirmeyi geri alıp Sadece Çizgiyi tek başına seçelim. Yukarıdan 

Modify>Transform>Flip Horizontal  işlemini uygulayarak çizginin başlangıç noktası ile bitiş noktasının yerlerini ters 

çevirelim. Bu işlem şeklin yatayda çevirir.  

 
 

 
Aşağıdaki şekilde düzgün gözüküyor ise sorun yoktur. Fakat yazı alanı tam doldurmuyor ise puntosunu büyütebiliriz. Ve ilk 

harften önce boşluk ekleyebiliriz.  

 

       
 

İşkur yazısını yerine koyduğumuzda çok küçük olduğunu görürüz. Bunu biraz daha büyütmek için Scale aracını kullanalım. 

Fakat yine de yazı tam düzgün olarak oturmuş değildir. Burada hatamız nedir?... 
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Hatamız şudur. Karabük Üniversitesi yazısı dairenin dışına konmuştu. Bu yazı ise Daireinin iç kısmına konmuştur. Her 

ikisindede aynı yarıçaplı daireyi kullandığımızdan bu hata oluştu. Oysa işkur yazısını şeklimizin dıştaki büyük daire 

kullanılarak yapılsaydı bu hata olmazdı. Bunlar tecrübeyle, zamanla öğrenilecek konulardır.  

 

  
Eğer yazımız yerine konulduğunda hale düzgün ve simetrik olarak durmuyor ise yukarıdan ikinci Ok sembülünü seçerek 

yazının belli noktalarından tutarak düzeltilmesi yapılabilir. Bu ikinci ok (beyaz renkli) seçilen cisimlerin üzerinde düzeltme 

yapmamızı sağlar.  

 

 
Logomuzun iç yukarı kısmına yarım daire şeklinde Üniversiteye ait bir resmi ekleyelim. Bunun için üniversiteye ait bir resim 

üzerinde daire şeklinde seçim aracını kullanarak belli bir bölgeyi seçelim. Seçimin elips değil de daire şeklinde olması için 

seçme işlemini yaparken bir elimizi shift tuşunda basılı tutalım. Sonra seçtiğimiz alanı Ctrl C ile kopyalayıp logonun 

bulunduğu sayfaya geçelim ve oraya yapıştıralım. Resmin büyüklüğünü logonun ortasına tam oturması için scale aracı ile bir 

miktar küçültelim. Resmi Dikdörtgen seçim aracı ile üst kısmını seçerek ikiye bölelim. Böldüğümüz alanı logonun üst 

yarısına yerleştirelim. Daha sonra kesilen yarı resim üzerinde Inner Bevel efekt uygulaması yapalım. Bu şekilde resmin alt 

kısmınada uygun bir çalışma yapalım.  
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UYGULAMA 5. HAREKETLİ BUTON ÇALIŞMASI  
 

Hareketli buton yapabilmek için Sadece resim hazırlamak yetmez, mouse üzerine geldiğinde resmi değiştirmek için html 

kodları içerisine kod yazmak gerekir. Bu kodları kendimiz yazmayacağız. Fireworks bizim arkaplana yazılacak kodları 

kendisi hazırlayacaktır. Biz sadece hareketli butonun mouse üzerine gelmeden önce, mouse üzerindeyken ve sayfa ziyaret 

ediltikten sonra ki görünümlerinin nasıl olacağını ayarlayacağız.  

 

Buton lar iki şekild kullanılabilir.  

a) Tamamen tasarımını kendimiz yaparak 

b) Fireworks un içerisindeki hazır butonları kullanarak . 

 

A) BUTONU KENDİMİZ HAZIRLAYALIM.  

 

Bu işlem için öncelikle 900x900 boyutlarında bir web sayfası tasarlayalım. Zemin renklerini aşağıdaki şekile 

ayarlayalım.  

 

 
 

Burada sol taraftaki sarı seridin olduğu bölüme hareketli butonlar ekleyeceğiz.  

 

Öncelikle sol tarafa sığacak büyüklükte kendi tasarımımız olan bir button hazırlayalım. Bu butonun şekli aşağıdaki 

şekilde olsun. Bu şekli hazırlarken Fireworksa Solda Vector yazan bölümdeki çizgi ve dikdörtgenleri kullanalım. 

Kenar rengi ve zemin renklerini ayarlayalım.  
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Kenar ve zemin renklerini ayarlamak için çizdiğimiz dikdörtgeni seçip aşağıdaki Properties (özellikler) penceresinden şu 

renkleri değiştirin.  

 

 
Burada dikdörtgeni seçip zemin rengini sarı, kenar rengini mavi, kenar çizgi kalınlığını 3 piksel, ve kenarlarını keskin hale 

(Hard Line) getirdik. Eğer sarı bölgenin içerisine bir desen atmak istersek Texture kısmında bu ayarlamayı yapabiliriz. 

Ayrıca dikdörtgenin tamamına gölge yada yükseklik hissi verdirmek istersek Filters daki + işaretine tıklayıp bu efekleri 

verebiliriz.  

 

Artık hazırladığımız şekli butona dönüştürebiliriz. Bunun için öncelikle hazırladığımız şekli seçiyoruz. Yukarıdan 

Modify>Symbol>Convert To Symbol yolunu kullanıp çıkan pencerede Buttons seçeneğiyle devam ediyoruz. 

 

 
 

Bu işlemden sonra seçtiğimiz alanın çevresine kendisi bir dikdörtgensel alan attı. Bu alanın anlamı bu kısımla ilgi Fireworks 

artık kendisi kod yazabilir demektir. Yani dışarıya atıldığında html (ve içerisinde javascript) kodlarını kendisi oluşturabilir.  

 
 

Butona düzenlemek için ortasındaki renkli çereçeveye çift tıklayıp butonu düzenleme ekranına geçelim. 
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Butonun ekranına geçtiğimizde Up yazan görünüm mouse butonun üzerine gelmeden önceki görünüm olacaktır. Over yazan 

sayfa mouse butonun üzerine gelince oluşak görünümdür. Down yazan kısım ise daha önceden butona tıklanıldı ise (yani 

sayfa ziyaret edildiyse) gözükecek görünümdür.  

 
 

Butonun üzerine konulacak yazıyı hazırlayalım. Bunu için sol taraftan A yazan butana tıklayıp yazımızı yazalım.  

 
 

Mouse butonun üzerine gelince oluşak tasarımı hazırlayalım. Bunun için Over yaprağına geçelim. Buraya geçtiğimizde 

sayfanın boş olduğunu görürüz. Diğer yaprakta hazırladığımız tasarımın buraya gelmesi için Copy Up Graphics (üst 

grafikten kopyala) butonuna tıklayalım. Tıkladıktan sonra bir kopyasının buraya geldiğini görürüz.  

 

 
 

Mouse butonun üzerine geldiğinde şeklinin değişmesi için Over yaprağında tasarım üzerinde bazı değişiklikler yapalım. 

 

 
Aynı şekilde Down sayfasına geçtiğimizdeki görünümü de şu şekilde ayarlayalım 

 

 
Buton hazırdır. Alt sağ köşedeki Done tuşuna basalım ve Buton tasarlama ekranından çıkalım. 

Buton tasarım ekranından çıkınca, Web sayfası tasarım ekranına dönmüş olduk. Hazırladığımız bu butonu tasarım da 

koyacağımız yere ortasından tutup sürükleyelim. Aynısında Ctrl C ve Ctrl V yaparak çoğaltalım. Çoğalttığımız diğer butonu 

önceki butonun altına sürekleyelim. Sürüklemeye hassas yapmak için klavyedeki Ok tuşlarını kullanalım.  
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İlk butonu seçip aşağıdaki properties penceresinden butona tıkladığımızda gidilecek sayfayı (Link verme), mouse üzerine 

geldiğinde gözükecek yazıyı (Alt yazan kısım), Açılacak sayfanın nasıl açılacağını (Target kısmı) ayarlayalım. 

 
 

Linklerimizi hazırlarken Google gibi dışarından bir siteye link veriyor isek mutlaka adresinin başlangıcın http:// kısmını 

yazmalıyız. Yani http://www.google.com.tr   şeklinde olmalı.  

 
 

B) FİREWORK UN İÇERİSİNDEKİ HAZIR BUTONLARIN KULLANILMASI 

 

Tasarımın sol üst köşesinde Fireworksun içerisinde bulunan hazır butonları kullanalım.  

 

Sayfanın sol üst köşesine köşeleri yuvarlak bir dikdörtgen atalım. Bu dikdörtgenin uçlarını yarıçapı küçültelim. Dikdörtgenin 

zemin kısmına bir desen verelim.  

 
 

Hazır butonları eklemek için Edit>Libraries>Buttons  kısmından beğendiğimiz bir butonu seçelim. 

 

http://www.google.com.tr/
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Sayfamıza butonu ekledikten sonra butonun kenarında gözüken kırmızı çizgilerin alanı büyük olabilir. Bu kırmızı çizgileri 

görmek yada gizlemek için Sol tarafta Web yazan kısımdaki iki butona tıklayarak ayarlama yapabiliriz. Butonu tasarımda 

bulunmasını istediğimiz yere sürükledikten sonra kenarındaki kırmızı çizgileri mouse ile sürükleyerek küçültelim. Bu işlemi 

yaparken kırmızı çizgilerin diğer kırmızı çizgilerle düzgün bir doğrultu oluşturması sayfanın daha az kısımlara bölüneceği 

anlamına gelir. Bu nedenle bu çizgilerin doğrultularına dikkat edelim.  

 
 

               
 

F12 ile kontrolü yaptığımızda hazır butonların yazı kısmının mouse ile değiştemediğini beyaz kaldığını görüyoruz. Sadece 

çevresine mor bir çizgi atıyor. Bu durum eğer yazının renginin mavi olmasını ister isek tekrar kırmızı çizgileri görebilemiz 

moda geçeriz. Butonlardan bir tanesinin üzerine çift tıklayıp butonun tasarım ekranına geçiş yaparız. Oradan Over sayfasında 

yazının rengini değiştirebiliriz.  

 

 
Kırmızı moda geçip ortadaki dairenin çıktığından emin olunca çift tıklayalım 

 
Çift tıklayınca Butonun tasarım ekranına geçeriz. Over sayfasına geçip yazıyı seçelim ve onun rengini açıkmavi olarak 

değiştirelim.  
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Ardından Done tuşa basıp web sayfası ekranın geçelim. F12 Test edelim. Mouse butonun üzerine gelince Beyaz yazı maviye 

dönüşmüş oldu.  

 
 

 

MOBİLYA MAGAZASI İÇİN WEB SİTE VE KATALOĞ UYGULAMASI 
 

Bir mobilya mağazası için içerisinde ürünlerin olduğu bir web sitesi hazırlayalım. Bu amaçla öncelikle hazırlayacağımız 

sitenin genel tasarımına karar verelim.  Genel Tasarım aşağıdaki görünüme benzesin.  

 

 
Canvas (Zemin, Tuval) ölçülerini belirleyelim.  600x400 olsun.  

Kullacağımız koltuk resimleri için Googledan bir çok koltuk resmi indirelim.  

 
 

Resimlerden birini dikdörtgen seçme aracı ile kopyalayıp Tasarladığımız sayfanın üzerine yapıştıralım. Ve oradaki 

boyutlarını Modify>Image Size kısmından Genişliği 100 olacak şekilde küçültelim.  
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Tasarıma attığımız resimlerin boyutlarını 100x80 ebatlarına düşürelim. Bunun için resmi seçip sol alt kısımdan ölçülerini 

değiştirelim. Resmi buraya getirmeden önce kesilen kenarların oranları yine 100 x 80 şeklinde olması gerekir. Örneğin 

kestiğimiz resmin genişliği 200 ebadında olursa bunun yüksekliği 160 olması gerekir. Yoksa resmi küçülttüğümüzde resim 

orantısı bozulmuş olarak gözükür. 

 
 

Resim boyutlarını ayarladıktan sonra resimler sayfa içerisinde aralıkları düzgün olarak durması için Resmin sayfanın sol 

kenarından  (X ölçüsü) ve Yukarı kenarından (Y ölçüsü) ölçülerini hesaplayarak ayarlayalım. 

 

 
 

Sayfanın Zemin rengini (Canvas rengini) değiştirelim. 
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Resimleri seçip çevresine 1 piksellik siyah renkli, bulanık kenarı olmayan, % 100 etki eden Glow efekti atalım. Aşağıdaki + 

işaretine tıklayarak.  

 
Mevcut resimlerin çevresine beyaz bir glow daha atalım. Ölçülerini aşağıdaki şekilde ayarlayalım.  

 
Ortadaki boş alana bir dikdörtgen çizelim. Bu dikdörtgeniş W,H, X, Y ölçülerini aşağıdaki şekilde ayarlayalım.  
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Ortadaki dikdörtgeni seçip kenarlarına iki defa önceki yaptığımız şekilde glow atalım.  

 
 

Soltaraftaki Slice tool aracını seçip (bu araç resmi parçalara ayırmayı ve html kodlarını otomatik oluşturmamızı sağlayan bir 

araçtır) Resmi hassas bir şekilde kenarların üzerinden giderek paraçalara ayıralım.  

 
Dikkat: Uygulamanın sonunda test ettiğimizde şu hatayı gördük. Burada butonların üzerinde Kırmızı çizgileri oluşturmayın. 

Zaten ileriki adımlarda bu resimler buton haline getirildiğinde kırmızı çizgileri kendisi oluşturmaktadır. İki defa kırmızı çizgi 

oluştuğu için hata meydana gelmektedir. Bu nedenle buradaki buton resimleri üzerinde kırmızı çizgi oluşturma uygulamasını 

iptal ediyoruz.  

 

Sayfanın diğer kısımlarını aşağıda görüdüğü şekilde kırmızı çizgilerle bölgelere ayıralım. Ortadaki bölgeyi Aşağıda 

gösterildiği şekilde hassas olarak ölçülendirelim. Bunun için önce bölgeyi seçmemiz lazım. Seçtiğimizi ortasında oluşan 

küçük daireden anlayabiliriz.  
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Küçük resimlere buton uygulaması yapalım. Bunun için öncelikle Kırmızı çizgileri kaldıralım.  Sol altta Web yazan yerden 

kaldıralım.  

 
Resimlerden bir tanesini seçelim, Aşağıdaki yolu kullanarak bunu butona dönüştürelim. 

   

 
 

Butonun üzerine çift tıklayıp, onun düzeltme ekranına geçelim 

 
Butonun üzerine mouse gelince resmin siyah-beyaz olmasını istiyoruz. Bu amaçla Over sayfasına geçelim. Sağ alttaki butona 

tıklayıp kopyasını bu sayfaya getirelim. 
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Sonra resmin kendisini seçip siyah/beyaz efektini verelim.  

 
Over sayfasında etrafındaki Beyaz glowun kaybolmaması için aşağıdaki şekilde efektlerin sıralmasını ayarlayın. Daha sonra 

Done tuşuna basıp butonu tamamlayın.  
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Bu şekilde tüm butonları hazırlayalım. F12 ile test ettiğimizde butonların grileştiğini görürüz.  

 
 

Dışarı Export edip Html sayfası ve Resimler şeklinde atalım. File>Export yolunu kullanalım. 

 



KARABÜK ÜNİVERSİTESİ, MÜHENDİSLİK FAKÜLTESİ, TEMEL BİLGİSAYAR KULLANIMI NOTLARI..............www.IbrahimCayiroglu.com 

 

 28 

 
Dışarı attıktan sonra Firework la işimiz bitmiştir. Daha sonra Dosyaları attığımız yere gidip baktığımızda hem html saymız 

hemde resimlerimizin bulunduğu klasörü (images) görürüz.  

 
 

Images klasörüne bir bakalım. Ne görüyoruz? 

 

 
Dikkat edersek butonların resimlerinde hem renkli resmi hemde siyah/beyaz resmi Fireworks bizim için oluşturup otomatik 

olarak bu kalasörün içerisine atmıştır.  

 

Peki sayfa çalışırken mouse renkli resmin üzerine geldiğinde siyah/beyaz resmi yüklemesi gerektiğini kim nasıl biliyorda 

bize gösteriyor? 

 

Bu sorunun cevabı html kodları içerisinde gizlidir. Dolayısıyla bunun cevabını Visual Studio net geçtiğimizde verelim.  

 

Şimdi Burada hazırladığımız siteyi VS. net geçip, orada yeni bir Asp.net projesi oluşturalım ve onun içerisine atalım. 

Notların bundan sonraki kısmı VS.net yada C# notları arasında devam edecektir.  
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WEB SİTELERİNE AÇILIR MENÜ (POP-UP MENÜ) UYGULAMASI 
 

Web sitelerinde bir linkin yada butonun üzerine mouse gelince başka sayfalara giden açılır bir menü uygularıyla sıklıkla 

karşılaşırız. Bu tip bir uygulama Dreamveawer ve Fireworks programları kullanılarak yapılabilir.  

 
Bu uygulamayı yapabilmek için yeni bir proje başlatalım. Projemizin konusu İstanbul ‘u tanıtan bir site olsun. Bununla ilgili 

bir resim alalım. Bunun sol üst köşesine butonlarımızı oluşturalım. Ve bu butonların üzerin mouse gelince yeni menüler 

açılsın. Ayrıca bir sonraki konuda işleyeceğimiz Resim maskeleme olayını bu manzara resmi üzerinde uygulayalım.  

 
Burada butonları koyacağımız zeminin içerisinden istanbulun manzarasını şeffaf olarak görmek istiyoruz.  Resmi şeffaf hale 

getirmek için çerçeveyi seçip aşağıdan özelliklerden alfa sını ayarlamalıyız. % 74 dolu hale getirdik 

  
 

Hazırladığımız çerçevenin içerisine hazır butonlar ekleyelim.  
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Hazır butonu ekledikten sonra kenarındaki kırmızı çizgilerden (buralar mouse un etkili olacağı alanı gösterir) küçültelim. 

 
 

Butonun kenar çizgilerini daralttıktan sonra eğer dıştaki çerçeve içerisine sığmıyor ise Scale Tool (Ölçekleme aracı) 

kullılarak butonlarda daha da küçültülebilir. Bir tane butonun büyüklüğü ayarlandıktan sonra kopyalarak çoğaltalım. 

 
Butonları çoğaltırken kenar çizgilerinin aynı hiza ve aralıkta olmasına özellikle dikkat edin. Bu işlemi daha hassas yapmak 

için mouse yerine klavyeyi kullanın.  

 
Kırmızı çizgileri gizlemek için aşağıdaki tuşa tıklayın. Bu çizgiler resmin bölüneceği  ve farenin çalışağı alanları gösterir.  

 
 

Tasarımımız hazırdır. Artık pop-up menü (açılır menü) uygulamasına geçelim.  

Butona açılır menü uygulaması yapmak için butonun kendisini seçelim (Kırmızı çizgiler görünür olsun). Ortasında küçük 

dairenin oluştuğuna dikkat edin. 
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Butonları hazırladıktan sonra ortadaki küçük daire üzerine tıklayalım. “Add Pop-up Menu” kısmından ekleyelim. 

 
Açılan pencereden linkin üzerinde yazacak yazıyı (Text), adresini (Link)ve sayfanın nerede açılacağını (Target) belirleyin. 

Linkleri kaldırmak ve eklemek için + ve  - işaretlerini kullanın. Bu şekilde linklerimizi yazdıktan sonra Done (Yapıldı bitti) 

tuşuna tıklayalım.  

 
Dikkat edersek açılır menü butonların üzerinde oluştu. Done tuşuna tıklamadan önce bazı ayarları yapmamız gerekiyordu. 

Şimdi aynı yere tekrar geri dönelim ve bu ayarları yapalım.  

 
Aynı yere geri dönelim, ortadaki küçük daireye tıklayalım, bu sefer “Edit Pop-up Menu” (açılır menüyü düzelt” kısmına 

girelim.  

 
 

Çıkan pencerede Apperance (Görünüm) , Advanced (Gelişmiş) ve Position (Konum) ayarlarını yapmak üzere sayfalar vardır. 
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Apperance (Görünüm) kısmından görünümle ilgili ayarları yapalım.  

 
Advanced (Gelişmiş ayarlar) kısmında bazı ayarları yapalım. Cell Padding (Hücre kenarı ile yazı arasındaki boşluğu)  Cell 

Spacing (İki hücre arasındaki boşluğu ayarlar) Border Width (Kenar kalınlığı) Menu Delay (açılır menünün gecikme zamanı 

) vs ayarlanabilir.  

 
Position (konum) kısmından açılır menünün sağ tarafta açılmasını sağlayan tuşa tıklayıp Done tuşuna basalım.  
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MASKELEME KONUSU 
Resimlerle çalışırken bazen resmin çevresini bulanık geçişli bir bir görünümde yapmak isteyebilir. Bazende resmin 

içerisinden Başka bir resmin süzgeçten süzer gibi geçişli olarak görülmesini isteyebiliriz. Yada bir resmin bir köşesinden 

diğer köşesine doğru gittikçe koyulaşan bir görüntü elde etmek isteyebilir. Bir yazıyı hazırlarken yazının içerisinden başka 

bir manzaranın görülmesini isteyebiliriz. Vs. bunun gibi onlarca uygulamayı yapabilmek için Maskeleme konusunu iyi 

bilmemiz gerekir.  

 

Bu konuyu anlayabilmek için şöyle düşünelim. Elimizde iki tane cam olsun. Bu camlardan alttakinde bir manzara resmi 

olsun. Üstteki cama bir yazı yazalım. Yazdığımız yazının dış kısımlarından ışık geçmediğini ve hiç bir şeyi göremediğimizi 

düşünelim. Üstten yazıya baktımızda acaba alttaki manzaranın yazının iç kısımlarından görmemiz mümkün müdür. 

Mümkündür fakat yazının kendi koyuluğu ışığın geçmesine engel olabilir yada yarı geçirgen olabilir. Bu durumda alttaki 

manzara resmi üstteki yazı ile maskelenmiş olacaktır.  

 

Bu işlemi yapabilmek için bir manzara resmimiz olsun. Bir de başka bir layer da bir yazımız olsun. Her iki layer ı seçip  

 

 
Kontrol tuşuna basılı tutarak her iki layerı seçelim. Ve aşağıda gösterilen yoldan bu iki layerı maskeleyelim. 
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Yukarıdaki uygulamaları incelediğimizde yazı için kullandığımız renk ne kadar koyu ise alt kısımdaki manzara görüntüsünü 

o kadar az geçiriyor. Yani siyahta hiç bir renk geçmiyor. Beyaz da ise renkler tam olarak geçiyor.  

Peki yazı soldan sağa doğru gittik koyulaşacak şekilde yazılır ise görüntü nasıl olacaktır.? 

Bunun için Gradiant Tool (geçişli boyama aracını) kullanalım.  

 

 
 

   
 

Şimdi bir başka uygulama yapalım. İki tane resmi üst üste çakıştıralım. Üstteki resmi maske olarak kullanalım.  
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Bu uygulamada maske olarak kullanılan üstteki resmin siyah bölgelerinden ışık geçmediği için o kısımlar beyaz kaldı. Daha 

açık olan sarı bölgelerden ışık geçtiği için alttaki güneş ve minarelerin dış kısmı (gökyüzü) daha görünür oldu. 

 

Bu resmi esas çalışmamıza atıp ve etrafına mavi bir glow eklediğimizde aşağıdaki görüntüyü elde ederiz.  

 
 

Bir uygulama daha ekleyelim. Bu sefer maske olarak bir şekil çizelim. Ve bu şeklin içerisinden istanbulun bir başka 

görüntüsünü görüntüleyelim.  

 
Beşken çizdikten sonra Gradient Tool aracını kullanarak ve Radial efektini kullanarak aşağıdaki görüntüyü elde edin. 

Kullanılan iki rengi ise oklarla gösterilen yerden ayarlayın.  
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Bu iki resmi maskelediğimiz zaman aşağıdaki görüntüyü elde ederiz. 

 
Maske ile ilgili başka ayarlar da yapmak ister isek layers kısmından sadece maskenini üzerine tıklayıp aşağıdan birçok 

özelliğini değiştirebiliriz.  

 
Bunlardan bazıları aşağıda gösterilmiştir.  
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Bu resminde beğendiğimiz bir görüntüsünü tasarımımız içerisine atalım. Son hali aşağıda şekilde oldu. 

 
Bu sayfayı F12 ile çalıştırdığımızda web sitesinin son hali aşağıdaki şekilde olacaktır.  Tabii web sitesi olarak internette 

yayınlabilmesi için Fireworks da Export (dışarıya atma, ihraç) etmemiz gerekir. Html sayfası ve resimler şeklinde.  

 

 
 

FİREWORKS DA BUTON RESİM ETKİLEŞİMİ UYGULAMASI 
 

Bir çok sitede butonların üzerine mouse gelince hemen yanındaki bir resim alanındaki resimlerin değiştiğini görmüşüzdür. 

Bu konuda Fireworks bize hiç bir program kodu yazmandan bir kolaylık sağlamaktadır. Aşağıdaki Adımları takip edin.  

 

Sayfanın Kanvasını 500x400 boyutlarına ayarlayıp hazır butonlar ekleyerek aşağıdaki görüntüyü oluşturun. 
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Sonra Frames Penceresini açınız.  

 
 

Frame penceresinin alt kısmından +  işaretinden buton sayınca frame ekleyin. 

 

 
Bu işarete tıkladığımızda sayfamızda 6 tane frame oldu. 1. Frame geçip sol taraftaki Slice Tool dan ortaya bir tane Kırmızı 

Çizgilerle bir tane dikdörtgen çizelim.  
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Oluşturulan bu yeşil alan butonlara tıkladığımızda Resimlerin nerede görüntüleneceğini belirleyecektir.  

 

Kırmızı Çizgilerle gösterilen alanı aşağıdaki şekilde gizleyelim.  

 

 
 

Her Frame sırayla seçip içerisine bir resim koyalım.  
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Resimleri yerleştirdikten sonra Kırmızı çizgilerin görünümünü tekrar açalım. 

 
Frame1 seçili iken Butona tıklayalım. Butonun ortasındaki beyaz nokta çıkınca buradan mouse ile tutup ortadaki alanın 

üzerine bırakalım. Bir çizgi oluşmuş demektir. Böylece Frame1 ile buton1 birbirine bağlamışız demektir.  

 

 
 

 


